cancel
Showing results for 
Search instead for 
Did you mean: 

ubuntu 19.04: Developer says libgit2.so.25 requires OPENSSL 1.0.0

simon_watson_sj
New Contributor III
Hi Team,
I have ubuntu 19.04 running and installed Developer. I did notice that it looks for specifically Ubuntu18 so understood I might be in for a bumpy ride. 

I get the error:
Error loading /home/simon/developer/ws/lib/q_git: /usr/lib/x86_64-linux-gnu/libssl.so: version `OPENSSL_1.0.0' not found (required by /home/simon/developer/ws/lib/libgit2.so.25)

This is after I put in a soft link libssl.so.1.0.0 -> libssl.so to "fix" the first error message looking for the file libssl.so.1.0.0

without this working, I can't initialise a repository and so can't open a q file. 

Has anyone been able to rig up a solution to running Developer on Ubuntu19.04? Weirdly, 1.0.0 is a really old version of OpenSSL. (1.1.0 would be the supported release)?

Regards,

Simon





1 REPLY 1

simon_watson_sj
New Contributor III
Hi All - update on this is I downgraded to Ubuntu18.04. All good now.