cancel
Showing results for 
Search instead for 
Did you mean: 

Advanced Capstone 3.6 need help

Aevar
New Contributor II

Hello, I have been stuck on this 3.6 for a while now. I have seen all the other threads related to this exercise but can't seem to solve it.

Here is my .z.pg code and the error I am getting.

 

Spoiler
hdbH".z.pg:{permission:.perm.users[.z.u;`api];test:.perm.parseQuery[x];$[permission~`all;value x;($[test~permission;value x;:`notAuthorized])]}"

Aevar_0-1698110294602.png

 

https://community.kx.com/t5/KX-Academy/Advanced-Capstone-3-6-exercise-help/m-p/14490

@fbibolottiThat is likely your issue - load the entire database rather than individual tables.

Comment from linked thread:
"I ended up resolving this problem, it was a very easy fix.  Rather than loading each table individually into the remote process (what I did), the database simply needs to be reloaded through the connection handle using "\l ."  Ensure that you are loading into the correct file path (I had to change directory down to the "f1" folder).  Hope this helps anyone else who ran into the same issue."

 

From reading the above, it seems that I have to load the database in the remote process but I don't think I am loading it with the right syntax.

 

 

hdbH:hopen `::5099

hdbH "load `:/home/jovyan/developer/workspace/__nouser__/adv_capstone/f1"
hdbH "get `:/home/jovyan/developer/workspace/__nouser__/adv_capstone/f1"

 

 

Any help would be much appreciated.

 

 
1 ACCEPTED SOLUTION

megan_mcp
Community Manager Community Manager
Community Manager

Hi @Aevar !

From what I can see your .z.pg code works fine. The issue, as you mentioned, is your code for loading in the database. 

Can you try replacing your lower two hdbH statements with:

hdbH"\\l f1"
hdbH"tables[]"

Line 1 is what the user described in the post you tagged - '\l' meaning load and 'f1' being the directory.

Let me know if this works!

Thanks,

Megan 🙂

View solution in original post

2 REPLIES 2

megan_mcp
Community Manager Community Manager
Community Manager

Hi @Aevar !

From what I can see your .z.pg code works fine. The issue, as you mentioned, is your code for loading in the database. 

Can you try replacing your lower two hdbH statements with:

hdbH"\\l f1"
hdbH"tables[]"

Line 1 is what the user described in the post you tagged - '\l' meaning load and 'f1' being the directory.

Let me know if this works!

Thanks,

Megan 🙂

Aevar
New Contributor II

Hi @megan_mcp 

Thanks very much for the help. I got it solved and submitted the project to receive the certificate.