cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with Audio Alerts on kx Dashboards

rcoen01
New Contributor II

Hi there,

I'm trying to set up an audio alert for a table in a kx dashboard with user input parameters. The datasource for the audio alert is empty to start with so that notifications are essentially off when the dashboard is loaded. Once the user inputs a set of parameters, the table is then populated. The issue I'm having is that the audio alerts work fine after I select the data source for the alerts and save but don't work after restarting the dashboard though the datasource is still selected. Is there a solution to this problem? 

1 ACCEPTED SOLUTION

We are interested to know what your datasource returns when the table is empty - is it an empty table with the same schema or something else? We are wondering if the table being empty means that the schema is undefined when starting and perhaps this impacts the audio alerts. 

Thanks for your cooperation, 

Leah 

View solution in original post

4 REPLIES 4

LeahS
Moderator Moderator
Moderator

Hello @rcoen01

Thanks for sharing with the community. Great content! 

We're working on feedback for you.

Happy Coding!

Leah 

LeahS
Moderator Moderator
Moderator

Given that you encounter this after a refresh, we would like to ask you to ensure that you have followed the steps below:

Here are the steps on how to allow audio on a chrome computer:
  1. Launch the Google Chrome browser on Computer.
  2. Click on  menu for options.
  3. Select Settings from the list.
  4. Scroll down to the Privacy and Security section, and select the Site settings from the menu.
  5. Choose the Sounds option within Site settings.
  6. Toggle the button to turn ON and allow the sound permissions.

Kind regards,

Leah 

rcoen01
New Contributor II

Hi Leah,

 

My Google Chrome browser was configured fine. I'm able to generate audio alerts if I select the data source I want to create the alerts but when I refresh the page, there are no alerts even though the data source has been selected. The table starts off empty until the user defines the parameters of the alerts, could that be causing the issue?

We are interested to know what your datasource returns when the table is empty - is it an empty table with the same schema or something else? We are wondering if the table being empty means that the schema is undefined when starting and perhaps this impacts the audio alerts. 

Thanks for your cooperation, 

Leah