cancel
Showing results for 
Search instead for 
Did you mean: 

Negative floats causing issues with range slider component

tomstocks43
New Contributor II

Hi All,

I’m having an issue with the “Range Slider” component. It seems to have incorrect behaviour when dealing with negatives, in my case, floats.

Below is 2 examples of range sliders. They are identical apart from the fact that the data source for the slider on the left has filter; where X >= 0.

 

tomstocks43_0-1625580602104.png

The slider on the left behaves as expected however the slider on the right has its draggable element locked to the far right. The draggable element will not move upon interaction.

This is the data source for the slider:

tomstocks43_1-1625580602106.png

I am only using the Selected Min Value and Selected Max Value view states as “outputs” of the slider.

The x axis type is configured as Number

6 REPLIES 6

dataGuyJosh
New Contributor II

Hi Tom!

At a glance, is it possible that the Selected Min/Max values actually constrain the range of the slider? (e.g. if the range doesn't include all values in the data source the component doesn't work correctly)

If not, my first step in debugging this would be to replicate it in a new dashboard (i.e. just setup a range slider or two with with the same data sources) as this can sometimes make the issue very apparent when you're setting it up the second time. If it DOES still occur post the xml for that test dashboard here and someone might be able to debug the issue from that.

Kind regards,

Josh

Thanks for the reply Josh,

I was able to replicate the issue in a blank Dashboard with Min/Max Selected view states within the range of the data source too.

I cant attach the XML as the website is saying the file type is not supported. Do you have an email address or something I can send it to?

tomstocks43_0-1625646441507.png

 

 

Hi Tom,

Try using pastebin for pasting the xml, thats how I got around attaching my logs on one of my threads 😄

dfallon
New Contributor III
New Contributor III

Thanks @adrianosm_ and @tomstocks43, we have this issue tracked. 

Declan

That's rude of it! I would suggest posting a pastebin URL or equivalent as adrianosm_ suggested because
- I won't necessarily have time to debug this
- other users might find a solution
- record keeping I guess?
It does seem annoying that a KX support page doesn't support file types KX uses 🙃

LeahS
Moderator Moderator
Moderator

Hello Contributors,

We are delighted to see you interacting and working together. We hope you are enjoying the site. Thank you very much for your contributions, they are very much appreciated.

With regards to XML, this has been added to our feedback/suggestions board internally. Thank you very much for your constructive feedback.

We hope you continue to benefit from the community and find the engagement fun. Thank you again for your contributions. 

Leah