Showing results for 
Search instead for 
Did you mean: 

How to resolve could not load q_util - .ax.rt.sharedLoadBulk error, when firing Kx-developer?

New Contributor

Hi, wish you are very well.

I am trying to use kx-developer on my windows 10. Right now kx developer is in a c:\q\dev. Navigating to 


and running

q c:\q\dev\analyst\launcher.q_

I get :

[developer] [!] couldn't validate install, proceeding with startup...
[developer] loading...
[developer] authentication is enabled
[developer] [!] could not load q_util - .ax.rt.sharedLoadBulk
[developer] [!] falling back to command-line authentication
[developer] failed to start Kx Developer: .axutl.repl.prompt



I would be very thankful, if someone can hint me at how to resolve the issue. 


Moderator Moderator

Hi Neekan,

Make sure you source your config file before running developer as per notes on Getting started - KX Developer

Kind regards,


Thanks David, 

I  made sure I source the config but I still get the same error. Can it be for having kx developer sitting in the same folder as q?


I don't think it's related to having Developer in the same folder (although I would suggest having it in its own location).

You perhaps may be missing some libraries that are required for authentication based on the log messages.

Can you try changing authentication to disabled in your config.bat and see if you can start Developer?