cancel
Showing results for 
Search instead for 
Did you mean: 

Getting License error

srevuri4
New Contributor II

Hi Floks,

I am new KDB, while running q session, I am getting below error.

Can you please help on this.

srevuri4_0-1667332365557.png

 

2 ACCEPTED SOLUTIONS

  1. Is QLIC set?
  2. Was this licence issued specifying it was for a windows machine?

View solution in original post

After Setting QLIC. Issue is resolved.

Thanks.

View solution in original post

9 REPLIES 9

mattdeshAQ
New Contributor

Hi,

Due to changes made by KX earlier this year, the use of kdb+ now requires a license.  Some details can be found from documentation by KX here: https://code.kx.com/q/learn/licensing/

I may not be able to fully assist with this as you may need to contact KX directly, but hopefully this can point you in the right direction!

 

Best Wishes,

Matt

srevuri4
New Contributor II

I went through the above link, I tried multiple ways but my issue is not resolved.

Environment

OS:- Win-11

What location is your licence file?

Have you set the QLIC environment variable?

Hi,

Below is my folder structure.

srevuri4_0-1667842806995.png

srevuri4_1-1667842858792.png

 

  1. Is QLIC set?
  2. Was this licence issued specifying it was for a windows machine?

After Setting QLIC. Issue is resolved.

Thanks.

voiddump
New Contributor

I tried multiple ways on my MacBook Pro and my VMFusion (whose environment supposedly is windows 11) but my issue is not resolved. My folder structure is as below: (The first is that on Mac, the second&third is that on VMFusion).

P.S. I would prefer KDB+ be installed on my Mac instead of on my VMFusion, if possible. But I would also really appreciate it if someone tell me how to solve the problem on my VMFusion.1st pic1st pic2nd pic2nd pic3rd pic3rd pic

 

First image looks fine for QHOME=/voiddump/q/m64

 

More traditional structure would be to not have that extra level of m64

.i.e 

  • voiddump/q/kc.lic
  • voiddump/q/q.k
  • voiddump/q/m64/q

In that case you'd use QHOME=/voiddump/q

I changed the QHOME to /voiddump/q and it works! Thank you so much!