Showing results for 
Search instead for 
Did you mean: 

Question about linux-arm version for Raspberry Pi

New Contributor
Hi every, just found this great place.

I recently got a rasp pi with 8GB memory. I heard about KDB is extremely fast, and I hope to do some web crawling stuff with the rasp PI. I have two questions:

1. should I run linux arm version for 32 bit? I tried that and shows "no such file or directory" when using ~/q/l32arm/q.
2. Can I run l64 version? I tried that, too, with message of "cannot execute binary file: Exec format error". It should be problem with 64 and 32 bit. As I have 8GB memory, I would want to use 64 bit for sure. Is that even possible?

many thanks for your kindly response and any information is welcome.


Valued Contributor
Valued Contributor

1. It is best to rename 'mv ~/q/l32arm ~/q/l32' . Also ensure you have ran 'export QHOME=~/q' 
2. No, l64 is for X86 (Intel/AMD) processors only. Currently there is only a 32bit ARM release.


Thanks very much for your reply.

I have tried your solution by renaming and profile change. But it still doesn't work with the same error message.

A simple question, I'm running on a ubuntu 64 server, for a l32arm version, will it be the cause of fail? is it even configurable to have i386 installed on arm version ubuntu?

Thanks for your response again.

New Contributor

Hi, I did the 'l32arm' to 'l32' directory rename, but I think what succeeded in getting the 32 bit arm version of q running on my aarch64 raspberry pi were the following two commands:

sudo apt-get update

sudo apt-get install libc6:armhf libstdc++6:armhf

After this, q ran OK, the "No such file or directory" message is gone.