cancel
Showing results for 
Search instead for 
Did you mean: 

RE: [personal kdb+] Large sym enumeration file

david_demner
New Contributor
X-Originating-IP: 174.7.128.233User-Agent: Workspace Webmail 5.14.9Message-Id: <20150717090912.85f80dae80d1d2f2e266ec6278e6cbe8.e0ba047d85.wbe@email07.europe.secureserver.net>From: "David Demner \(AquaQ\)" To: personal-kdbplus@googlegroups.comSubject: RE: [personal kdb+] Large sym enumeration fileDate: Fri, 17 Jul 2015 09:09:12 -0700Mime-Version: 1.0

I did this a few months ago and the system did get a bit more stable/responsive.

Fairly painful but the only way is to rewrite all your sym columns (after you change the offending column to string as you say).

Good luck....
-------- Original Message --------
Subject: [personal kdb+] Large sym enumeration file
From: Roni Hoffman <hoffmanroni@gmail.com>
Date: Fri, July 17, 2015 8:57 am
To: personal-kdbplus@googlegroups.com

Hi All, I noticed something kind of troubling today.  The sym enumeration file in my hdb seems very large.  Its about 400mb and contains 4.5mill entries.  When I inspected it I noticed I have items in there that I may not want including orderIds. When I use .Q.dpft to store tables all the symbol columns got enumerated there.

Couple questions,
This will cause slower queries correct?
This doesn't seem like an easy/quick fix.  I think I would have to change all columns I don't want enumerated there to either strings or their own enumeration.  Then create a new sym file.  Can someone help me think about a correct fix for this, if its needed?


--
You received this message because you are subscribed to the Google Groups "Kdb+ Personal Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to personal-kdbplus+unsubscribe@googlegroups.com.
To post to this group, send email to personal-kdbplus@googlegroups.com.
Visit this group at http://groups.google.com/group/personal-kdbplus.
For more options, visit https://groups.google.com/d/optout.
0 REPLIES 0