cancel
Showing results for 
Search instead for 
Did you mean: 

KX Developer on Macbook M1 or M2

mhickman
New Contributor
New Contributor

Is there a way to install KX Developer on Macbooks with M1 or M2 processors? Because when I run install.sh, it returns a message stating that only x86_64 architectures are supported when M1 and M2 is built on ARM64.

1 ACCEPTED SOLUTION

davidcrossey
Moderator Moderator
Moderator

Hi mhickman,

I don't believe ARM64 is officially supported at this time, however you could try using Rosetta to run Intel based applications on your ARM64 based mac: If you need to install Rosetta on your Mac – Apple Support (UK)

You will also need to install Developer's dependencies via the Rosetta terminal i.e. brew install [x]

Kind regards,
David

David

View solution in original post

1 REPLY 1

davidcrossey
Moderator Moderator
Moderator

Hi mhickman,

I don't believe ARM64 is officially supported at this time, however you could try using Rosetta to run Intel based applications on your ARM64 based mac: If you need to install Rosetta on your Mac – Apple Support (UK)

You will also need to install Developer's dependencies via the Rosetta terminal i.e. brew install [x]

Kind regards,
David

David