cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with KDB install

Cantaro86
New Contributor

Hi guys,


I have installed kdb+ (64 bit) from Anaconda. I got the confirmation email and set QHOME to the path containing kc.lic, q.k and l64.

However, when I try to start q I get


KDB+ 3.6 2018.12.24 Copyright (C) 1993-2018 Kx Systems

'2019.04.29T09:49:37.666 couldn't connect to license daemon -- exiting


My internet connection works properly.

Any idea?

Thank you.

5 REPLIES 5

jwbuitenhuis
New Contributor
That's what I get in the tube 🙂
Are you possibly running your kdb in a VM and are you sure the VM is connected to your laptop's wifi?

I have a RHEL7 VM and unless I tell it something like this it will not wifi:

# dhclient -r && dhclient


Then it must be sure the internet works at the VM before kdb was mounted.

在 2019年4月30日星期二 UTC+8上午6:24:19,JW Buitenhuis写道:
That's what I get in the tube 🙂
Are you possibly running your kdb in a VM and are you sure the VM is connected to your laptop's wifi?

I have a RHEL7 VM and unless I tell it something like this it will not wifi:

# dhclient -r && dhclient


Hi JW, thanks for the reply.

I'm not using any VM. I just installed kdb+ with conda on my local machine (I have Ubuntu 16.04).
I tried to ping www.kx.com getting
# 4 packets transmitted, 4 received, 0% packet loss, time 3003ms



Il giorno martedì 30 aprile 2019 00:24:19 UTC+2, JW Buitenhuis ha scritto:
That's what I get in the tube 🙂
Are you possibly running your kdb in a VM and are you sure the VM is connected to your laptop's wifi?

I have a RHEL7 VM and unless I tell it something like this it will not wifi:

# dhclient -r && dhclient


Cantaro86
New Contributor
All firewalls are disabled.

Cantaro86
New Contributor
ISSUE SOLVED:

the problem was that the $http_proxy environment variable was set.
After unsetting it, the program works normally.

Thanks